SCU URP 助手「Bookmarklet 版」通用安装教程

(2020-3-26 更新)注意!书签版 SCU URP 助手的托管源从码云修改为了 GitHub(由 jsDelivr 提供 CDN 服务)!如果你的书签是在 2020 年 3 月 26 日之前创建的,请删除掉旧的书签,重新拖一次,否则将无法正常使用!

虽然使用 Userscript 是最方便的办法,但有的同学可能不会安装使用 Userscript,一些国产浏览器甚至可能不能安装 Tampermonkey 这样的用户脚本管理器,对于这部分同学,我还提供了 Bookmarklet 版本,就是一个集成在书签工具栏上的按钮,单击一下就可以加载使用。

只需要将下面这个链接,拖动到书签工具栏即可:

SCU URP 助手

然后打开综合教务系统的任意页面,点击书签工具栏上的「SCU URP 助手」按钮,等待几秒后即可加载程序。

SCU URP 助手「Bookmarklet 版」通用安装教程》有14个想法

    1. 王兆基 文章作者

      如果你使用的是 UserScript 版本,脚本管理器如果没有自动更新,可以手动检查一下更新,应该就可以了~
      如果你使用的是书签版,但版本还是 0.9.37 的话,可能是你的浏览器存在本地缓存,可以用浏览器打开网址「https://cdn.jsdelivr.net/gh/frederick-wang/scu-urp-assistant/dist/scu-urp-assistant-bookmarklet.js」,并且按 Ctrl+F5 强制刷新一下,应该就可以了~

      回复
    1. 王兆基 文章作者

      由于 CDN 缓存服务的原因,上午发的 0.10.1 版本需要一段时间才能同步到书签版哦,可能你使用书签版时,加载出来的版本还是 0.9.37 版本~我刚才看了一下,现在书签版已经更新到 0.10.1,可以正常使用了。

      回复
    1. 王兆基 文章作者

      由于 CDN 缓存服务的原因,上午发的 0.10.1 版本需要一段时间才能同步到书签版哦,可能你使用书签版时,加载出来的版本还是 0.9.37 版本~我刚才看了一下,现在书签版已经更新到 0.10.1,可以正常使用了。

      回复
  1. 万丁源

    书签的版本是不是没有更新嗷,然后 greasy fork 脚本下载了之后无法安装,显示 12 行缺少标识符

    回复
    1. 王兆基 文章作者

      因为使用了 jsDelivr 的 CDN 服务,而 CDN 会将脚本缓存下来,所以书签版的自动更新会延迟一天左右,需要等待 jsDelivr 更新服务器文件缓存后,才能加载出最新版本。如果继续用书签版,大概等一天左右就可以使用最新版了。请问你用的是什么浏览器配的什么脚本管理器安装 greasyfork 上的 Userscript 的呢,我刚才测试了一下是正常的。

      回复
        1. 王兆基 文章作者

          我的环境和你一致。刚才我先删除了我之前 Tampermonkey 里的脚本,然后重新在 GreasyFork 上安装了一下,是正常的,安装后也没有出问题。我猜测会不会是你那边网络环境的问题呢?会不会是网络有波动,造成脚本没有完整下载完,从而提示出错的。

          回复
          1. 万丁源

            很感谢回答,但是问题没有得到解决,与此同时使用 tampermonkey 下载其他 greasyfork 的脚本并没有出现错误,应该不是网络问题

            回复
            1. 王兆基 文章作者

              迷茫……我这里一直是正常的。如果您那边始终提示错误的话,也可以用书签版~我刚才看了一下,CDN 上的书签版已经同步到 0.10.1 了~

              回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注